Browsers and Security

Security vulnerabilities are a fact of life. As they become recognised, patches are usually made available, but some occur inside protocols which cannot be patched, only upgraded to a new secure version. So it is essential your browser is kept up-to-date, as that is the only genuine protection against such vulnerabilities.

Below is Studentnet's list of recommended versions for popular browsers, and the minimum version level Studentnet networks will support. Anything less than the recommended version may leave you and your systems open to exploits, attacks and password/data theft.

Recommended Browser Versions

Platform Browser Minimum
Supported
Recommended
Version
Notes
Windows Internet Explorer 7 11 TLS 1.1/1.2 support is available in 11+
Windows Chrome All versions Latest TLS 1.1/1.2 is available in 30+
Windows Firefox 1+ 31 TLS 1.1/1.2 support is available in 27+, disabled by default in 26
Mac Safari All versions 7 (iOS 10.9) TLS 1.1/1.2 support is available in OS X 10.9
Mac Chrome All versions Latest TLS 1.1/1.2 in 30+
Mac Firefox 1+ 31 TLS 1.1/1.2 in 27+, disabled by default in 26
iOS Safari All versions iOS 8 iOS5 is required for TLS 1.1 / TLS 1.2
Android Chrome All versions Latest TLS 1.1/1.2 in 30+
Android default Android 2.2 Android 4.x Default browser in 4.x does not appear to support TLS 1.1 or 1.2